miércoles, 9 de abril de 2008

experiencias con el dni electrónico

Recientemente me renové el dni y obtuve el esperado dni electrónico. Después de buscar por la web y encontrar un dispositivo que fuera compatible, según decía el frabicante, con Linux y MacOsX, me decidí a comprarlo.
El fabricante tiene instrucciones para instalar su producto en Linux y Win, pero no para Mac, aunque en el mini-cd que acompaña al dispositivo tiene paquetes para mac.Después de realizar muchas búsquedas por la red y encontrar sca donde hay una lista de incompatibilidades con Leopard pude empezar la tarea.
Al ver que  el aparato no termina de funcionar acabo de mandar un correo para ver si dan soporte.

Actualización: c3po me ha contestado y me ha mandado un patch para Leopard ya que la version de ccid parece que es el problema. Después de la actualziación no he tenido problemas para utilizar el dnie.
Actualización: 10.5.6 incluye open source CCID library v1.3.8 y parece que soluciona los problemas. Importante: la versión del sca debe ser 0.2.3pre2 para que funcione la carga del modulo.